WSS

Jun 20, 2009 at 8:36 AM

Hello,

can I use this webpart on WSS3?

Coordinator
Jun 20, 2009 at 12:21 PM

You should be able to dann23. The Application Pages were developed and tested under a WSS3 environment.


From: dann23 [mailto:notifications@codeplex.com]
Sent: Saturday, June 20, 2009 4:37 AM
To: cham625@cinci.rr.com
Subject: WSS [sitesecuritymgmt:60144]

From: dann23

Hello,

can I use this webpart on WSS3?

Read the full discussion online.

To add a post to this discussion, reply to this email (sitesecuritymgmt@discussions.codeplex.com)

To start a new discussion for this project, email sitesecuritymgmt@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jun 20, 2009 at 4:43 PM

Thank for the prompt response. I asked because I tried to install it on WSS3 and I get unknown error when I access the webpart. And I activated EnableSessionState. I hope I did it right. Do you know how to debug this error?

Coordinator
Jun 21, 2009 at 1:34 PM

Can you modify the web.config to turn off custom error messages? This would give the true error that is occurring. If you haven’t done this before, this should help you out:

http://stevepietrek.com/2007/07/28/turn-off-sharepoint-custom-error-messages/


From: dann23 [mailto:notifications@codeplex.com]
Sent: Saturday, June 20, 2009 12:44 PM
To: cham625@cinci.rr.com
Subject: Re: WSS [sitesecuritymgmt:60144]

From: dann23

Thank for the prompt response. I asked because I tried to install it on WSS3 and I get unknown error when I access the webpart. And I activated EnableSessionState. I hope I did it right. Do you know how to debug this error?

Read the full discussion online.

To add a post to this discussion, reply to this email (sitesecuritymgmt@discussions.codeplex.com)

To start a new discussion for this project, email sitesecuritymgmt@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jun 23, 2009 at 12:46 PM

I modified web.config  to turn off custom error mesages and now it's working. Don't know why but it works. I'll test on a real server to see whats happening.

But I have a problem. When I check to change permissions at a certain level, it breaks inheritence at that level but the users I add there are added up to the top of the site. So this sucks because we have a generic group that gives read access to all users and it's not necessary to add every users to the entire structure. Can you help me on this problem?

Thank you.

Coordinator
Jun 23, 2009 at 10:51 PM

Hmm…I wonder if you just needed an iisreset. More than likely if you revert your web.config changes it should still work.

Regarding the security question, if you grant the group access at the List level (or any lower level) without giving them access to the parent level (i.e. Site) SharePoint grants them access to the parent level with the Limited Access permission mask. This doesn’t give them true access to the parent, but is more of a placeholder for SharePoint.

Per Microsoft:

Limited Access

The Limited Access permission level is designed to be combined with fine-grained permissions to give users access to a specific list, document library, item, or document, without giving them access to the entire site. However, to access a list or library, for example, a user must have permission to open the parent Web site and read shared data such as the theme and navigation bars of the Web site. The Limited Access permission level cannot be customized or deleted.

Note You cannot assign this permission level to users or SharePoint groups. Instead, Windows SharePoint Services 3.0 automatically assigns this permission level to users and SharePoint groups when you grant them access to an object on your site that requires that they have access to a higher level object on which they do not have permissions. For example, if you grant users access to an item in a list and they do not have access to the list itself, Windows SharePoint Services 3.0 automatically grants them Limited Access on the list, and also the site, if needed.

Sorry if this is way more than what you wanted.


From: dann23 [mailto:notifications@codeplex.com]
Sent: Tuesday, June 23, 2009 8:46 AM
To: cham625@cinci.rr.com
Subject: Re: WSS [sitesecuritymgmt:60144]

From: dann23

I modified web.config to turn off custom error mesages and now it's working. Don't know why but it works. I'll test on a real server to see whats happening.

But I have a problem. When I check to change permissions at a certain level, it breaks inheritence at that level but the users I add there are added up to the top of the site. So this sucks because we have a generic group that gives read access to all users and it's not necessary to add every users to the entire structure. Can you help me on this problem?

Thank you.

Read the full discussion online.

To add a post to this discussion, reply to this email (sitesecuritymgmt@discussions.codeplex.com)

To start a new discussion for this project, email sitesecuritymgmt@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jun 24, 2009 at 5:38 AM

I understand. But  what I was trying to say is that I don't need limited access to parent site because I already have a group with read access. I only restrict who has access to modify documents and there are tons of groups and all of them will be visible in the parent site with limited access.

Coordinator
Jun 24, 2009 at 3:24 PM

Unfortunately this is default SharePoint behavior.  It sees the groups as two seperate entities and therefore grants Limited Access accordingly.  By default, you can sort the Permissions column but adding a filter option would be a good enhancement.

Jun 24, 2009 at 3:47 PM

But if I do it manually it works. For example if I break inheritance at level 3, level 1 and 2 don't change and from level 3 down to the last level I set the groups that I want. But if I use your program, level 1 and 2 have the group that I added but with limited access. And it isn't needed because I already have a group for read only. So what I ask is if it is possible to make this webpart not to change the permission for the upper levels.

Coordinator
Jun 24, 2009 at 8:05 PM

I just ran the following test with OOB SharePoint:

Site A allows Domain Users read access.

Site A contains a Document Library with a Word doc in it.

User Bob has no special rights and doesn’t show up with the Limited Access permission mask.

On Site A, I granted user Bob Contribute rights to the Word doc.

Going to the user permissions at the Site level, Bob now has Limited Access.

I’m wondering if we’re missing something. The above was done with no code and all OOB. Could you layout your manual scenario? On a side note, are you using the singe or bulk edit piece of SSMU? Single edit mode just uses the OOB SharePoint controls and wraps the UI around them. Bulk edit mode is the only mode that sets security through code.


From: dann23 [mailto:notifications@codeplex.com]
Sent: Wednesday, June 24, 2009 11:47 AM
To: cham625@cinci.rr.com
Subject: Re: WSS [sitesecuritymgmt:60144]

From: dann23

But if I do it manually it works. For example if I break inheritance at level 3, level 1 and 2 don't change and from level 3 down to the last level I set the groups that I want. But if I use your program, level 1 and 2 have the group that I added but with limited access. And it isn't needed because I already have a group for read only. So what I ask is if it is possible to make this webpart not to change the permission for the upper levels.

Read the full discussion online.

To add a post to this discussion, reply to this email (sitesecuritymgmt@discussions.codeplex.com)

To start a new discussion for this project, email sitesecuritymgmt@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jun 25, 2009 at 11:31 AM
Edited Jun 25, 2009 at 11:32 AM

You're right. I checked the permissions on the top site. That's why I didn't see the groups with limited access. My mistake. Thank you for your help.